New Guy...Old Capri

GustHo

New Member
Thread starter #1
Hey all, I've just joined. I bought my Capri 14.2 over 20 years ago and have had it in dry-dock (outside, under a tarp...lol) for about a decade. All rigging and sails have been stored indoors. A friend's son would like to sail and asked me if I could launch Gust-Ho. Actually after replacing the trailer tires, the boat looks pretty "shipshape." See for yourself (attached pic). My problem is that I can't locate the owner's manuel, so rigging could be trouble. Any ideas and comments will be appreciated.
 

Attachments

GustHo

New Member
Thread starter #3
Bingo!

jmike said:
Perhaps this would help?
No "perhaps" about it jmike. This is exactly what I need. Thank you VERY MUCH.
Today I attached the swivel block with cam cleat and hiking buckles to the barney post. I'm sure I'll have more questions as I try to reassemble the boat.
 
#6
Eric,

Back in March of this year I attended the Pacific All Sail Expo in Oakland, CA and there was a new Capri 14.2 at the show. It was identical to my 86' except for the roller furling jib. All of the rigging, both standing and running were the same.

They truly are a one design. Nice to know that I have basically and identical boat for which I paid $850 with trailer and the new one was $6500!!

Fair Winds,

Brad
Capri 14.2 #1108
 
#8
No Eric, I purchased the just this year and I am the 4th owner. I have been able to track down the 2nd owner and he had purchased it from a neighbor who no longer lives near him. Unfortunately I was unable to figure out why the sail numbers differ from the boat.
 
#9
Hi Brad,
You propably have a different sail number because one of the previous owners bought a used main from another sailor. I do know one person that put # 1212 on the sail because that is the day and month of her husband's birthday. It's not a hugh deal either way until you sail in a regatta with the sail that has a sail number that is there on the right guy's boat. Nothing a duck tape "1" won't fix.
Bob
 

GustHo

New Member
Thread starter #10
She floats...

I finally got #776 (without rigging & sails) off land and into water. Gust-Ho has been perched on her trailer for well over a decade. I'm pleased to report that she is indeed water tight. However, I did encounter some trouble lowering the center board, clogged solid with leaves, rubble and an aggravated ant nest. All seems to be working well now.

I was able to power the boat with an old DieHard (20 lb. thrust) electric and a new battery. Unfortunately, after about 5 minutes of operation the motor started to smoke and all but the "Mega Thrust" speed stopped working. Alas, I was able to power about for over an hour...enough time to finish my safety checks.

I'm guessing that it doesn't pay to repair this very old, not often used, motor. Can anyone suggest a new electric motor replacement to go with a newly purchased DieHard Deep Cycle Marine battery? In any event, I'm hoping to finish the rigging and be under sail very soon!
 
#11
GustHo said:
Can anyone suggest a new electric motor replacement to go with a newly purchased DieHard Deep Cycle Marine battery? In any event, I'm hoping to finish the rigging and be under sail very soon!
I put a Minn Kota Riptide 40 on my boat and it works pretty good. The Riptide series is designed for resisting salt water which makes it a bit more expensive. If you don't sail in salt water, Minn Kota has other, less expensive models. I found the best prices at Cabela's online.

Hope this helps,
Jim
 

GustHo

New Member
Thread starter #12
Thanks Jim for Minn Kota input...I've been surfing their info. online including Cabela's. Do you attach your MK directly to the transom or have you installed a motor mount? Btw, how many hours use, before recharging, can you get?
 
Thread starter #13
What's wrong with this?

The manuel says the traveler length should be 6'-2", but I've also read here that the traveler apex should be 28" above the transom. When I cut a new 6'-2" traveler, its transom apex is only 17". Did I do something wrong? :confused:
 
Top